Suddenly unable to edit existing template

admin304
14 Posts
admin304 posted this 02 May 2017

Existing site that has been using Themler successfully for close to a year. Last update was about 30 days ago with no problems.

Edit template now button fails - on click, site home page is displayed inside the themler login popup window
Install plugins = Request failed: 403
Import Content from Template = Request failed: 403

Existing site that has been using Themler successfully for close to a year. Last update was about 30 days ago with no problems. Edit template now button fails - on click, site home page is displayed inside the themler login popup window Install plugins = Request failed: 403 Import Content from Template = Request failed: 403
Vote to pay developers attention to this features or issue.
24 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 03 May 2017

Hi,

The 403 error means that there is not enough permissions.
As I understand you're using Joomla.
Did you install new joomla components which may change folder permissions? Such as Admin Tools or something similar.

Thank you,
Olivia

Hi, The 403 error means that there is not enough permissions. As I understand you're using Joomla. Did you install new joomla components which may change folder permissions? Such as Admin Tools or something similar. Thank you, Olivia
admin304
14 Posts
admin304 posted this 03 May 2017

Recent Installs:
- Ark editor & Media Manager
- My Content and Workflow
- Youtube Feed Pro

Recent Installs: - Ark editor & Media Manager - My Content and Workflow - Youtube Feed Pro
admin304
14 Posts
admin304 posted this 03 May 2017

Admin Tools was installed, but disabled months ago

Admin Tools was installed, but disabled months ago
Support Team
Support Team posted this 03 May 2017

Hello,

Please try these steps:
1. Temporary disable all third-party CMS plugins and components.
2. Clear cache:
http://answers.themler.com/articles/8713/error-sorry-an-error-has-occurred-please-clear-your-browser-cache
3. Clear AppCache. Use Chrome browser for this:
http://answers.themler.com/articles/14063/how-to-clear-appcache
Let us know if the issue is still present.

Sincerely,
Nettie,
BillionDigital Team

Hello, Please try these steps: 1. Temporary disable all third-party CMS plugins and components. 2. Clear cache: http://answers.themler.com/articles/8713/error-sorry-an-error-has-occurred-please-clear-your-browser-cache 3. Clear AppCache. Use Chrome browser for this: http://answers.themler.com/articles/14063/how-to-clear-appcache Let us know if the issue is still present. Sincerely, Nettie, BillionDigital Team
admin304
14 Posts
admin304 posted this 03 May 2017

Disabling all CMS plugins and components will be a major disruption to our site. I will try one at a time and let you know the result as soon as possible.

Disabling all CMS plugins and components will be a major disruption to our site. I will try one at a time and let you know the result as soon as possible.
Support Team
Support Team posted this 03 May 2017

Hello,

I see. Then yes, just please disable them one-by-pne, this is needed to find out if there is a conflict with any of them. We will be waiting for your results.

Sincerely,
Nettie,
BillionDigital Team

Hello, I see. Then yes, just please disable them one-by-pne, this is needed to find out if there is a conflict with any of them. We will be waiting for your results. Sincerely, Nettie, BillionDigital Team
admin304
14 Posts
admin304 posted this 04 May 2017

Unable to resolve issue. I'm creating a test environment to allow me to disable everything except Themler. I will get back to you in 24 hrs.

Are there any other things I can look at?

Unable to resolve issue. I'm creating a test environment to allow me to disable everything except Themler. I will get back to you in 24 hrs. Are there any other things I can look at?
Support Team
Support Team posted this 04 May 2017

Hello,

If disabling plugins and components does not help, you may try also temporarily disabling also antivirus and firewall and test. Just in case, please make sure that the user and group running the web server are granted the appropriate read, write and execute (linux only) permissions on the following folders, as well as read and write permission on the files in these folders:

root/templates
root/plugins
root/tmp

Sincerely,
Nettie,
BillionDigital Team

Hello, If disabling plugins and components does not help, you may try also temporarily disabling also antivirus and firewall and test. Just in case, please make sure that the user and group running the web server are granted the appropriate read, write and execute (linux only) permissions on the following folders, as well as read and write permission on the files in these folders: root/templates root/plugins root/tmp Sincerely, Nettie, BillionDigital Team
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 18 May 2017

i have done all of the above, but still no result.

I have some Joomla! sites that have this issue and the themler templates are all a bit older, so they don't have the latest version of themler and probably not even the version before that.
I do want to update these templates, so please help me.

i have done all of the above, but still no result. I have some Joomla! sites that have this issue and the themler templates are all a bit older, so they don't have the latest version of themler and probably not even the version before that. I do want to update these templates, so please help me.
Support Team
Support Team posted this 18 May 2017

Hi Edwin,

May we ask you to create a new private ticket and provide us with a temp access to your Joomla back-end there so we can try to help you.

Thanks,
Ivan

Hi Edwin, May we ask you to create a new private ticket and provide us with a temp access to your Joomla back-end there so we can try to help you. Thanks, Ivan
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 20 May 2017

Oke, i have created a private ticket

Oke, i have created a private ticket
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 24 May 2017

I think the problem occurs when your themler version that is included in the template is to old.
I have an answer from the Themler team.
Maybe this can also help someone else. It worked fine for me.

For those sites where you just cannot press Edit template button there is a manual fix that allows you to open a template and update it to the latest version.

So here is what you need to do:
1.Open <theme_name>/app/classes/Config.php file
2.Find the following line:

$editor = JRequest::getVar('editor', '');

and insert the following piece of code before it

JHtml::_ ( 'behavior.modal' ); // for SqueezeBox

I think the problem occurs when your themler version that is included in the template is to old. I have an answer from the Themler team. Maybe this can also help someone else. It worked fine for me. For those sites where you just cannot press **Edit template** button there is a manual fix that allows you to open a template and update it to the latest version. So here is what you need to do: 1.Open &lt;theme_name&gt;/app/classes/Config.php file 2.Find the following line: $editor = JRequest::getVar('editor', ''); and insert the following piece of code before it JHtml::_ ( 'behavior.modal' ); // for SqueezeBox
admin304
14 Posts
admin304 posted this 13 June 2017

I think the problem occurs when your themler version that is included in the template is to old.
I have an answer from the Themler team.
Maybe this can also help someone else. It worked fine for me.

For those sites where you just cannot press Edit template button there is a manual fix that allows you to open a template and update it to the latest version.

So here is what you need to do:
1.Open <theme_name>/app/classes/Config.php file
2.Find the following line:

$editor = JRequest::getVar('editor', '');

and insert the following piece of code before it

JHtml::_ ( 'behavior.modal' ); // for SqueezeBox

This is not the issue, that line is already there.

> I think the problem occurs when your themler version that is included in the template is to old. > I have an answer from the Themler team. > Maybe this can also help someone else. It worked fine for me. > > For those sites where you just cannot press **Edit template** button there is a manual fix that allows you to open a template and update it to the latest version. > > So here is what you need to do: > 1.Open &lt;theme_name&gt;/app/classes/Config.php file > 2.Find the following line: > > $editor = JRequest::getVar('editor', ''); > > and insert the following piece of code before it > > JHtml::_ ( 'behavior.modal' ); // for SqueezeBox This is not the issue, that line is already there.
admin304
14 Posts
admin304 posted this 13 June 2017

Is it possible that using security on our site from the vendor "Sucuri" is causing the issue?

Is it possible that using security on our site from the vendor "Sucuri" is causing the issue?
Support Team
Support Team posted this 13 June 2017

Hi,

The following folders (and folders) should have read/write/execute recursive permissions:
root/templates
root/plugins
root/tmp

If on of the installed joomla components changed the permissions you may face the reported issue.
Did you check folder permissions?

Thank you,
Olivia

Hi, The following folders (and folders) should have read/write/execute recursive permissions: `root/templates root/plugins root/tmp ` If on of the installed joomla components changed the permissions you may face the reported issue. Did you check folder permissions? Thank you, Olivia
DaveOzric
540 Posts
DaveOzric posted this 13 June 2017

Did you create a custom .htacess file with Admin Tools or any other tool? You must allow certain things for Themler to work.

administrator/templates/system
templates/yours
templates/manifests
plugins/content/themlercontent
plugins/content/themlerexportimport
plugins/editors-xtd/themlerbutton
tmp
language/en-GB

Use FireFox tools network tab to see what's being blocked.

Did you create a custom .htacess file with Admin Tools or any other tool? You must allow certain things for Themler to work. administrator/templates/system templates/yours templates/manifests plugins/content/themlercontent plugins/content/themlerexportimport plugins/editors-xtd/themlerbutton tmp language/en-GB Use FireFox tools network tab to see what's being blocked.
admin304
14 Posts
admin304 posted this 15 June 2017

It looks like one area is the autologin. When I attempt to edit, the login box pops up but rather than seeing the themler login I'm seeing a distorted view of my sites home page.

It looks like one area is the autologin. When I attempt to edit, the login box pops up but rather than seeing the themler login I'm seeing a distorted view of my sites home page.
Support Team
Support Team posted this 16 June 2017

Hi,

Unfortunately the issue with login screen is not quite clear. Could you please provide a few screenshots that demonstrate the issue?

Thank you,
Olivia

Hi, Unfortunately the issue with login screen is not quite clear. Could you please provide a few screenshots that demonstrate the issue? Thank you, Olivia
admin304
14 Posts
admin304 posted this 16 June 2017

<img>themler-1: The template page. I click EDIT TEMPLATE

<img>themler-2: The screen turns dark with an overlay and this popup box appears in the center. At that point I can do nothing except close the page. What you are seeing is a distorted logo image for our site along with home page nav items.

I have multiple themler accounts. Previously, this popup box was where I logged in to Themler. It used to look like:
<img> themler-login

themler-1.png

themler-2.png
themler-login.png

&lt;img&gt;themler-1: The template page. I click EDIT TEMPLATE &lt;img&gt;themler-2: The screen turns dark with an overlay and this popup box appears in the center. At that point I can do nothing except close the page. What you are seeing is a distorted logo image for our site along with home page nav items. I have multiple themler accounts. Previously, this popup box was where I logged in to Themler. It used to look like: &lt;img&gt; themler-login !themler-1.png! !themler-2.png!!themler-login.png!
admin304
14 Posts
admin304 posted this 21 June 2017

Any update? I'm not going to be able to resolve this issue on my own,

Any update? I'm not going to be able to resolve this issue on my own,
You must log in or register to leave comments