Please note that the company has been hijacked by its CTO Oleg Dudko and product manager Eugene Zvyagintsev who lied to their customers and investors, abandoned products they worked on, while renaming our product ArtisteerX to UPage and registering it under their personal domain. These people have no future in tech industry and we are no longer able to trust this team. This company will be closed and website discontinued on July 31st.

Not able to export on Desktop version

Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 08 May 2017

I get the feeling that that the team from Themler wants me to use the desktop version.
I do have an issue with the MAC-version. I have updated it to v.367 and still is problem is not fixed.
Another Themler-user i know has the same issue.

I am not able to export a zip-file. I think this is a mayor issue. I get no error and get the screen where i can select if i want to include some stuff, but when ik click on the button to export, nothing happens.

I get the feeling that that the team from Themler wants me to use the desktop version. I do have an issue with the MAC-version. I have updated it to v.367 and still is problem is not fixed. Another Themler-user i know has the same issue. I am not able to export a zip-file. I think this is a mayor issue. I get no error and get the screen where i can select if i want to include some stuff, but when ik click on the button to export, nothing happens.
Vote to pay developers attention to this features or issue.
15 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 10 May 2017

Hi,

We've released the new Beta update today. Does the issue continue with this latest beta update?

Thank you,
Olivia

Hi, We've released the new Beta update today. Does the issue continue with this latest beta update? Thank you, Olivia
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 10 May 2017

And where can i find this new beta version?
It's not installed automaticaly, there is no information about it on http://answers.themler.com/news and when i download the software i still get version 1.0319.fe25b

And where can i find this new beta version? It's not installed automaticaly, there is no information about it on http://answers.themler.com/news and when i download the software i still get version 1.0319.fe25b
Support Team
Support Team posted this 11 May 2017

Hello,

We mean the update not of the .dmg file but of Themler - there should be "1" in the red circle on the top right. You may need to check the box next to "Get Beta updates" in your profile to receive the Beta update notification. After installing the Beta update you may uncheck the box at an time.

Sincerely,
Nettie,
BillionDigital Team

Hello, We mean the update not of the .dmg file but of Themler - there should be "1" in the red circle on the top right. You may need to check the box next to "Get Beta updates" in your profile to receive the Beta update notification. After installing the Beta update you may uncheck the box at an time. Sincerely, Nettie, BillionDigital Team
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 11 May 2017

I have installed the beta, but still i can't export to a zip from the themler desktop application

I have installed the beta, but still i can't export to a zip from the themler desktop application
Support Team
Support Team posted this 11 May 2017

Hello,

Please try the following
1. Make sure to enable cookies in Safari browser.
2. Please try to open Themler through a browser using this link
http://127.0.0.1:29958/themler_582023301/startup/

Try different browsers like Safari, Firefox, Chrome and to export. Please let us know the result.

As a temporary solution, you may copy the theme manually from the folder with themes. Please click Go >> Go to Folder >> type ~/Library and ENTER >> Themler >> hd_data >> cms >> choose CMS and access the themes folder, copy the theme, zip it and install on your hosted website.

Sincerely,
Nettie,
BillionDigital Team

Hello, Please try the following 1. Make sure to enable cookies in Safari browser. 2. Please try to open Themler through a browser using this link http://127.0.0.1:29958/themler_582023301/startup/ Try different browsers like Safari, Firefox, Chrome and to export. Please let us know the result. As a temporary solution, you may copy the theme manually from the folder with themes. Please click Go >> Go to Folder >> type `~/Library` and ENTER >> Themler >> hd_data >> cms >> choose CMS and access the themes folder, copy the theme, zip it and install on your hosted website. Sincerely, Nettie, BillionDigital Team
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 12 May 2017

I have tried this way in Safari and Google Chrome,
Cleared cache, deleted cookies
I can view the sample on http://127.0.0.1:29958/themler_582023301/joomla/
i do get a page on /startup where i can select a platform, but when i select Joomla i get a page full of errors (see attachment).

I have also disabled the AMPPS version i have running, because i thought that maybe that could be part of the solution, but that didn't make a difference.

When i use the Themler desktop application i do get the ability to edit my theme, but not in a browser.

I have tried this way in Safari and Google Chrome, Cleared cache, deleted cookies I can view the sample on http://127.0.0.1:29958/themler_582023301/joomla/ i do get a page on /startup where i can select a platform, but when i select Joomla i get a page full of errors (see attachment). I have also disabled the AMPPS version i have running, because i thought that maybe that could be part of the solution, but that didn't make a difference. When i use the Themler desktop application i do get the ability to edit my theme, but not in a browser.
Support Team
Support Team posted this 12 May 2017

Hi,

Can you access to the joomla admin panel?
http://127.0.0.1:29958/themler_582023301/joomla/administrator
admin/admin
If so please try to start a few themes. Does the issue happen with all themes or with specific one? If the issue happens with specific theme please attach it to this topic.

We also suggest that you try reinstalling Themler application. For this please download the most recent version from http://themler.com

Thank you,
Olivia

Hi, Can you access to the joomla admin panel? http://127.0.0.1:29958/themler_582023301/joomla/administrator admin/admin If so please try to start a few themes. Does the issue happen with all themes or with specific one? If the issue happens with specific theme please attach it to this topic. We also suggest that you try reinstalling Themler application. For this please download the most recent version from http://themler.com Thank you, Olivia

Last edited 12 May 2017 by Support Team

Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 12 May 2017

I was able to enter the admin area en found a possible source for the problem. There where 2 templates with the same name. When i opened the editor from the Joomla back-end it started and i was able to save the zip file.

Since i wasn't able to use Themler in a proper matter i didn't have a lot of stuff that i wanted to keep. U uninstalled themler and i also deleted the complete folder /Users/myusername/Library/Themler/ so there would be nothing left from the stuff associated with the Themler application.

After that i downloaded and installed the latest version.

  • First test was to create a new Joomla! template, rename it, save it and then try to export the zip. That didn't work, so after a clean install it still doesn't work.
  • Then i installed the beta update, save the template again and tried to export the zip. This still doesn't work.
  • I was able to preview in the browser by using the button in Themler
  • I was NOT able to goto the Joomla! backend with the button in Themler.
  • Closed the Themler desktop application en started it again. Now i noticed that there are 3 templates. One is the backup that is made when i installed the beta release and the other ones both have the same name.
  • When i open one of the templates (with the same name) i get the editor and i can change some stuff and save that.
  • I can still preview in a browser and still the button for backend is not working. This is logical because the URL that is called is http://127.0.0.1:29958/themler_582023301/joomla/templates/untitled/app/index.php?auto_authorization=1&username=admin&password=admin&returnUrl=http%3A%2F%2F127.0.0.1%3A29958%2Fthemler_582023301%2Fjoomla%2Fadministrator and there is no untitled template anymore because i renamed it.
  • When i change the "untitled" part in the URL to the name i have renamed my template to (clean_template) I get the backend of the Joomla website.
  • When i use http://127.0.0.1:29958/themler_582023301/joomla/administrator/ i also get the Joomla! backend
  • When i look in the list of templates in the Joomla Backend i also see templates with the same name again.
  • When i look in my directory structure i see a folder with the name "untitled" and a folder with the name "clean_template". The both seem to contain all the files of the themler template.
  • When i open the editor from one of the templates in the Joomla backend it is working and i am able to export a zip-file.

I have tried the complete tests above on several Macbooks. All with the same result. These are different models but do all have the latest MacOS (Sierra 10.12.4). I had this problem on earlier versions of MacOS too.

So my conclusion is:

  • The URL that leads to the Joomla! backend from the desktop application isn't working because it contains the wrong template name.
  • Even after the beta version it is not possible to export a zip-file from Themler Desktop version

I was able to enter the admin area en found a possible source for the problem. There where 2 templates with the same name. When i opened the editor from the Joomla back-end it started and i was able to save the zip file. Since i wasn't able to use Themler in a proper matter i didn't have a lot of stuff that i wanted to keep. U uninstalled themler and i also deleted the complete folder /Users/myusername/Library/Themler/ so there would be nothing left from the stuff associated with the Themler application. After that i downloaded and installed the latest version. - First test was to create a new Joomla! template, rename it, save it and then try to export the zip. That didn't work, so after a clean install it still doesn't work. - Then i installed the beta update, save the template again and tried to export the zip. This still doesn't work. - I was able to preview in the browser by using the button in Themler - I was NOT able to goto the Joomla! backend with the button in Themler. - Closed the Themler desktop application en started it again. Now i noticed that there are 3 templates. One is the backup that is made when i installed the beta release and the other ones both have the same name. - When i open one of the templates (with the same name) i get the editor and i can change some stuff and save that. - I can still preview in a browser and still the button for backend is not working. This is logical because the URL that is called is http://127.0.0.1:29958/themler_582023301/joomla/templates/untitled/app/index.php?auto_authorization=1&username=admin&password=admin&returnUrl=http%3A%2F%2F127.0.0.1%3A29958%2Fthemler_582023301%2Fjoomla%2Fadministrator and there is no untitled template anymore because i renamed it. - When i change the "untitled" part in the URL to the name i have renamed my template to (clean_template) I get the backend of the Joomla website. - When i use http://127.0.0.1:29958/themler_582023301/joomla/administrator/ i also get the Joomla! backend - When i look in the list of templates in the Joomla Backend i also see templates with the same name again. - When i look in my directory structure i see a folder with the name "untitled" and a folder with the name "clean_template". The both seem to contain all the files of the themler template. - When i open the editor from one of the templates in the Joomla backend it is working and i am able to export a zip-file. I have tried the complete tests above on several Macbooks. All with the same result. These are different models but do all have the latest MacOS (Sierra 10.12.4). I had this problem on earlier versions of MacOS too. **So my conclusion is:** - The URL that leads to the Joomla! backend from the desktop application isn't working because it contains the wrong template name. - Even after the beta version it is not possible to export a zip-file from Themler Desktop version
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 12 May 2017

Extra:

I wanted to check if i could fix it by deleting a record in the database, so that there are no double records, but i was not able to acces phpmyadmin or the MySQL database with another tool.

http://localhost:12080/phpmyadmin
Server Address: 127.0.0.1
Server Port: 12306
Login: root
Password:

In the configuration i found that the used port for MySQL is 29954 and with a tool i could connect to the database
Strange thing was that there where no double records for the template styles in the database

Extra: I wanted to check if i could fix it by deleting a record in the database, so that there are no double records, but i was not able to acces phpmyadmin or the MySQL database with another tool. http://localhost:12080/phpmyadmin Server Address: 127.0.0.1 Server Port: 12306 Login: root Password: In the configuration i found that the used port for MySQL is 29954 and with a tool i could connect to the database Strange thing was that there where no double records for the template styles in the database
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 12 May 2017

I have done another test by saving the template under a different name with the function "Save a copy as".
After that i selected this new name as default template in Joomla!.
Now i was able to delete the double templates from the manage extensions functionality from Joomla!

I have also found the "untitled" template from the discover functionality from Joomla! and installed it that way.
Now the button in Themler Desktop to open the Joomla! backend is working again.

The problem to export as a zip still remains

I have done another test by saving the template under a different name with the function "Save a copy as". After that i selected this new name as default template in Joomla!. Now i was able to delete the double templates from the manage extensions functionality from Joomla! I have also found the "untitled" template from the discover functionality from Joomla! and installed it that way. Now the button in Themler Desktop to open the Joomla! backend is working again. The problem to export as a zip still remains
Support Team
Support Team posted this 12 May 2017

Hello,

Thanks for letting us know. Now as the initial issue is no more present, could you please try once more opening Themler in a browser like suggested above and let us know if there is any difference if you try to export a theme in this way?

Sincerely,
Nettie,
BillionDigital Team

Hello, Thanks for letting us know. Now as the initial issue is no more present, could you please try once more opening Themler in a browser like suggested above and let us know if there is any difference if you try to export a theme in this way? Sincerely, Nettie, BillionDigital Team

Last edited 12 May 2017 by Support Team

Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 12 May 2017

I can export from within the browser

I can export from within the browser
Support Team
Support Team posted this 12 May 2017

Hello,

We recommend to consider using this as a workaround. In fact, running Themler in a browser is an alternative way, Themler is fully functional in this way. You may try using this way for export only or also work in a browser if you would prefer to.

Sincerely,
Nettie,
BillionDigital Team

Hello, We recommend to consider using this as a workaround. In fact, running Themler in a browser is an alternative way, Themler is fully functional in this way. You may try using this way for export only or also work in a browser if you would prefer to. Sincerely, Nettie, BillionDigital Team
Scorpion Computers & Software
68 Posts
Scorpion Computers & Software posted this 13 May 2017

I surely hope that this will be a temporary solution. If you create a desktop version and promote to use this instead of the online version. I understand that the online version of saving templates with my account costs a lot of diskspace and you don't want that. I can imagine that this is one of the main reasons for creating a desktop version.

I do think however that you can't give your paying customers a product that is only half working. So i really think that this workaround is not acceptable for most paying customers.

Maybe you should consider a different version of the LAMPP that is build in your application. The one that is build in is not very recent and could just solve your issues.

I have personally spend a lot of time free testing this issue, so i would appreciate if you would not just chose the easy way and communicate this as a workaround.

I surely hope that this will be a temporary solution. If you create a desktop version and promote to use this instead of the online version. I understand that the online version of saving templates with my account costs a lot of diskspace and you don't want that. I can imagine that this is one of the main reasons for creating a desktop version. I do think however that you can't give your paying customers a product that is only half working. So i really think that this workaround is not acceptable for most paying customers. Maybe you should consider a different version of the LAMPP that is build in your application. The one that is build in is not very recent and could just solve your issues. I have personally spend a lot of time free testing this issue, so i would appreciate if you would not just chose the easy way and communicate this as a workaround.
Support Team
Support Team posted this 13 May 2017

Hi,

Thanks for your feedback. The desktop version is an alternative to Themler theme installed on some other host, like live host or localhost, and all these options is still present. The fact is that the issue with export on Mac is still not reproducible for us, for any CMS and with any update, including the latest Themler update. Still as it is reproducible in individual cases, it looks like some conflict in each particular case with some third-party software or installed browsers. That is why running Themler through a browser directly can be a workaround. We are sorry for this inconvenience. You may also consider working with Themler on a localhost or hosted website, export should work without any issues in this case.

Sincerely,
Nettie,
BillionDigital Team

Hi, Thanks for your feedback. The desktop version is an alternative to Themler theme installed on some other host, like live host or localhost, and all these options is still present. The fact is that the issue with export on Mac is still not reproducible for us, for any CMS and with any update, including the latest Themler update. Still as it is reproducible in individual cases, it looks like some conflict in each particular case with some third-party software or installed browsers. That is why running Themler through a browser directly can be a workaround. We are sorry for this inconvenience. You may also consider working with Themler on a localhost or hosted website, export should work without any issues in this case. Sincerely, Nettie, BillionDigital Team

Last edited 13 May 2017 by Support Team

You must log in or register to leave comments