Pages cannot be customized separately

Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Dont know if it is only my Artisteer converted Theme or. If you want theme as attachment make this topic private.

  • I made new Page template "Contact".
  • Made some CMS Code block, shortcode block
  • Posts and Sidebars tabs have "Customized this template" clicked.

  • I make new one called "Links".

  • Controls from "Contact" are copied there and deleting them delete controls in "Contact" too.
  • All controles are copied to native Page template.

  • If I mark whole container with all post content things to delete I get warning if I want to delete only for this template or for all shared templates.

  • I chose only this template, it is deleted on all Page templates.

I am trying to delete post content and insert new one to see if controls will be copied again, but cannot get to this part of work now.

Dont know if it is only my Artisteer converted Theme or. If you want theme as attachment make this topic private. - I made new Page template "Contact". - Made some CMS Code block, shortcode block - Posts and Sidebars tabs have "Customized this template" clicked. - I make new one called "Links". - Controls from "Contact" are copied there and deleting them delete controls in "Contact" too. - All controles are copied to native Page template. - If I mark whole container with all post content things to delete I get warning if I want to delete only for this template or for all shared templates. - I chose only this template, it is deleted on all Page templates. I am trying to delete post content and insert new one to see if controls will be copied again, but cannot get to this part of work now.
Vote to pay developers attention to this features or issue.
47 Comments
Order By: Standard | Newest
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Sorry, in exemple above first one is "Links", next maid Page template is "Contact". But point is the same.

Maybe one solution for now would be to make "Custom template" and name filename right to be recognized as Page templates.
Will try this.

Sorry, in exemple above first one is "Links", next maid Page template is "Contact". But point is the same. Maybe one solution for now would be to make "Custom template" and name filename right to be recognized as Page templates. Will try this.

Last edited 07 August 2015 by Stagger Lee

Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Can you give us an option to force clear what templates share one control/block ?
When we right click on a control we can se where it is shared but in no way we can there force it to not be shared on some templates.
Something as sidebars have, but for controls and blocks. On/off option for some templates.

Can you give us an option to force clear what templates share one control/block ? When we right click on a control we can se where it is shared but in no way we can there force it to not be shared on some templates. Something as sidebars have, but for controls and blocks. On/off option for some templates.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Why would one custom Page template control be shared on default Blog template.
I dont understand it.

Why would one custom Page template control be shared on default Blog template. I dont understand it.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

  • Now I tested by setting all templates (even default ones) to "Customize this template".
  • Deleted control.
  • Inserted new one, and it is still shared between Page templates and Blog default template.

I dont understand it.

Other problem is maybe it is not good to set all templates to "Customize this template". It generates an awful lot of unnecessary code.

  • It is shared via post content block, not control self. But why.

- Now I tested by setting all templates (even default ones) to "Customize this template". - Deleted control. - Inserted new one, and it is still shared between Page templates and Blog default template. I dont understand it. Other problem is maybe it is not good to set all templates to "Customize this template". It generates an awful lot of unnecessary code. - It is shared via post content block, not control self. But why.

Last edited 07 August 2015 by Stagger Lee

Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

  • I made new one Custom with "page-{slug}.php ".
  • Deleted old Page template.
  • Controls and Post content are still shared around.
  • I dont have options "Customize this template" for new one "page-{slug}.php ".

- I made new one Custom with "page-{slug}.php ". - Deleted old Page template. - Controls and Post content are still shared around. - I dont have options "Customize this template" for new one "page-{slug}.php ".

Last edited 07 August 2015 by Stagger Lee

Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

I see now, controls are outside Post content control. It is normal, they cannot be added in Post content. Only before-after WP content. At least I could not find a way to do it.

But, why they are shared.

I see now, controls are outside Post content control. It is normal, they cannot be added in Post content. Only before-after WP content. At least I could not find a way to do it. But, why they are shared.

Last edited 07 August 2015 by Stagger Lee

Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Solved it this way:

  • In "Links" Page template Sidebar tab - Show on... i disabled for Blog, Page and "Contact" Page template
  • Went to all those templates and activated again all this, fixed styling, etc.
  • Now controls are not shared around.
  • I got again Customize template style options and checked them all.

Man, it should not be so complicated and secret. Something is very wrong here.

Solved it this way: - In "Links" Page template Sidebar tab - Show on... i disabled for Blog, Page and "Contact" Page template - Went to all those templates and activated again all this, fixed styling, etc. - Now controls are not shared around. - I got again Customize template style options and checked them all. Man, it should not be so complicated and secret. Something is very wrong here.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Now when I insert one control (if it is same control I copy/shared last) it insert in this control (row) all things i shared before.
And as it is shared deleting in one template delete from others.

Man, this AppCache is making crazy things and takes lot of time to fix after it.
I prefer slow Themler as before, but one that works.

AppCache makes all possible weird things.

Now when I insert one control (if it is same control I copy/shared last) it insert in this control (row) all things i shared before. And as it is shared deleting in one template delete from others. Man, this AppCache is making crazy things and takes lot of time to fix after it. I prefer slow Themler as before, but one that works. AppCache makes all possible weird things.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

I solved it by first adding container control (not shared att all, and not in the cache), then inserted row inside container. Later I drag and drop row outside container and deleted container.

Can you leave all other things aside and take a general look at AppCache function.
When new features and options come problems will just multiply and multiply.

I solved it by first adding container control (not shared att all, and not in the cache), then inserted row inside container. Later I drag and drop row outside container and deleted container. Can you leave all other things aside and take a general look at AppCache function. When new features and options come problems will just multiply and multiply.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Now I inserted in one column of this inserted row shortcode control.
Screen freezes, I reload it, and AppCache (or wahtever) for some reason insert there my left sidebar making endless loop and site and Themler crashes on this template. Now I have to go manually to remove all of it.

Now I inserted in one column of this inserted row shortcode control. Screen freezes, I reload it, and AppCache (or wahtever) for some reason insert there my left sidebar making endless loop and site and Themler crashes on this template. Now I have to go manually to remove all of it.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

It works this way as an workaround:

  • Make new custom Page template
  • Some shared controls/blocks will be directly visible on it.
  • Go to the Page (or other) template where shared contrrol/block has its source, first one you made.
  • Show on template, disable for newly made Page template
  • Go to the new Page template and Show on template, activate again.
  • Shared controls/blocks are gone.
  • Dont forget to click again on both Customize this template options for new Page template.
  • After switching visibility in Show on template it resets.
  • Style further

It is obvious this process reset AppCache. I am not sure if AppCache makes this, but I strongly believe.

As time pass I am more advanced with Themler, yet I spent more times on fixing prooblem and bugs, instead of working on it.
It simply means Themler worked before as much stable.

What is general, global for all options, what i a big change compared to time when Themler was pretty stable ? AppCache.
Not new options, because problems are almost everywhere.

There are other small problems but had no lust to opet topics for all.
For instance styling comments, cannot go to the custom font sizes, It gives me some list and allways options for Posts, or Comments in general. Never suboptions in Comments. And it is something I dont have workaround for, cannot bypass it.

It works this way as an workaround: - Make new custom Page template - Some shared controls/blocks will be directly visible on it. - Go to the Page (or other) template where shared contrrol/block has its source, first one you made. - Show on template, disable for newly made Page template - Go to the new Page template and Show on template, activate again. - Shared controls/blocks are gone. - Dont forget to click again on both Customize this template options for new Page template. - After switching visibility in Show on template it resets. - Style further It is obvious this process reset AppCache. I am not sure if AppCache makes this, but I strongly believe. As time pass I am more advanced with Themler, yet I spent more times on fixing prooblem and bugs, instead of working on it. It simply means Themler worked before as much stable. What is general, global for all options, what i a big change compared to time when Themler was pretty stable ? AppCache. Not new options, because problems are almost everywhere. There are other small problems but had no lust to opet topics for all. For instance styling comments, cannot go to the custom font sizes, It gives me some list and allways options for Posts, or Comments in general. Never suboptions in Comments. And it is something I dont have workaround for, cannot bypass it.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Amazing, those damn shared controls pops up everywhere.
What purpose has option "Customize template style".

Amazing, those damn shared controls pops up everywhere. What purpose has option "Customize template style".
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Stop answering just licence and desktop questions. You have luck people have not started to use Themler properly. Otherways you would be burried with support questions.

Stop answering just licence and desktop questions. You have luck people have not started to use Themler properly. Otherways you would be burried with support questions.
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

Tried something different to run away from this problem.

  • Has one custom Page template that doesnt have any shared controls.
  • Duplicated this Page template, gave it another name, and this one has shared controls.

How is that possible ???!!

Tried something different to run away from this problem. - Has one custom Page template that doesnt have any shared controls. - Duplicated this Page template, gave it another name, and this one has shared controls. How is that possible ???!!
shaulhadar
400 Posts
shaulhadar posted this 07 August 2015

Hi Stagger, i am also checking the best way to do this.
Actually i was able to do this with good results some time back, but now i am not able to do it again, i am not sure but something changed somewhere..... i will check it also and if i find anything i will let you know....

Hi Stagger, i am also checking the best way to do this. Actually i was able to do this with good results some time back, but now i am not able to do it again, i am not sure but something changed somewhere..... i will check it also and if i find anything i will let you know....
shaulhadar
400 Posts
shaulhadar posted this 07 August 2015

I found that if you drag and put elements out of the sidebar areas it works, i will continue to check it out and see if its connected i kind of succeeded in doing one page template , and another different one with a widget area that is only on the new page template and is not shared.....

I found that if you drag and put elements out of the sidebar areas it works, i will continue to check it out and see if its connected i kind of succeeded in doing one page template , and another different one with a widget area that is only on the new page template and is not shared.....

Last edited 07 August 2015 by shaulhadar

shaulhadar
400 Posts
shaulhadar posted this 07 August 2015

Ok, I checked some more and for me it works good when i put things out of the sidebar area...
I made a screencast, maybe it will help you. i made there three different page templates.... and all work good i think.

Until Themler makes the content editor for pages, this is the best we can do to use themler to edit different pages and page templates...

Hope it help man :)

Ok, I checked some more and for me it works good when i put things out of the sidebar area... I made a screencast, maybe it will help you. i made there three different page templates.... and all work good i think. Until Themler makes the content editor for pages, this is the best we can do to use themler to edit different pages and page templates... Hope it help man :)
shaulhadar
400 Posts
shaulhadar posted this 07 August 2015

here it is in a .rar file, in case it matters...

here it is in a .rar file, in case it matters...
Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

When you mentioned sidebar. Sometimes sidebar has styling as Homepage/default, sometimes it has not. But OK, it is one Artisteer converted theme and it remembers old style sometimes.

Sometimes copy style/paste works in sidebar, sometimes not. There are no rules at all.

Problem is I dont get logic. This is very Themler specific, not some commom webdesign knowledge. That is why we need more video tutorials on shared controls, shared this and that, shared style.

Just one additional to report. I copy one row with Headline from Home, paste and share it on custom Page template, row on Home change width to something else. Despite in Outline looks the same on both.
As I sad no rules to follow. Problem can kick out anytime.

Spent whole day on it and results are 4 custom Page template. It would go faster to code manually. It should not take so much time. I am just fixing different problems, and wondering why I cannot open some of the "More options".

When you mentioned sidebar. Sometimes sidebar has styling as Homepage/default, sometimes it has not. But OK, it is one Artisteer converted theme and it remembers old style sometimes. Sometimes copy style/paste works in sidebar, sometimes not. There are no rules at all. Problem is I dont get logic. This is very Themler specific, not some commom webdesign knowledge. That is why we need more video tutorials on shared controls, shared this and that, shared style. Just one additional to report. I copy one row with Headline from Home, paste and share it on custom Page template, row on Home change width to something else. Despite in Outline looks the same on both. As I sad no rules to follow. Problem can kick out anytime. Spent whole day on it and results are 4 custom Page template. It would go faster to code manually. It should not take so much time. I am just fixing different problems, and wondering why I cannot open some of the "More options".

Last edited 07 August 2015 by Stagger Lee

Stagger Lee
1774 Posts
Stagger Lee posted this 07 August 2015

I recently tested something simple. When shared controls happens out from nowhere on new added custom Page template.
It works (not allways) if I just disable content area for Page template, Save and enable it again. But dont forget again klick on Customize template style, ot you can lose hours and hours of your work.

It is a bug. Cannot be normal state.

I recently tested something simple. When shared controls happens out from nowhere on new added custom Page template. It works (not allways) if I just disable content area for Page template, Save and enable it again. But dont forget again klick on Customize template style, ot you can lose hours and hours of your work. It is a bug. Cannot be normal state.
You must log in or register to leave comments